Abs, traction control, hill stability and at oil temp light blinking in 2013 Subaru Impreza sport. Also cruise control doesn't work.

You are watching: Subaru 3 warning lights on brakes traction control and at oil temp



Update- the at oil temp is the giveaway it is not the brake light switch. It was a transmission gasket and Subaru covered the repair. Thanks for all the help everyone



This happened to me today, the ABS, hill park assist and traction control lights all came on while driving to work. After work I couldn't get my car out of park. I had to pop off the little panel by the P next to the shifter and push a button down in there to manually get it out of park. Glad I looked here before going to the dealership.

Edit: I got the new part in and everything is working as it should


I had this happen on the Impreza I purchased last month. Symptoms you described happened intermittently with me. Then I got stuck at a gas station when I couldn’t get the car started because the switch failed entirely. Since the switch was broken I couldn’t get the car started and had to have it towed to the dealer to get it replaced.

TL/DR fix it now before you get stuck somewhere.


I have one of these for when this sort of thing happens.

Everyone should have one.https://www.ebay.ca/itm/Bluetooth-Mini-ELM327-OBD2-II-Auto-Car-OBD2-Diagnostic-Interface-Scanner-Tool/332333712008?hash=item4d60a20288:m:mOtAb_xAzblz2wSDE8bRn_Q


I had this happen. It's your brake light switch, located behind your brake pedal. Here is the part on Amazon: (https://www.amazon.com/Genuine-Subaru-83311FJ001-Switch-Stop/dp/B00JEHI8WC). You should also be able to get it at your local dealership. It's around $15 - $25. Make sure you get the Genuine Subaru Part. I bought one from Auto Zone, it fixed the lights and getting out of park but not the curse control. Then I replace it with a Genuine Subaru Part and it fix everything.

It's a fairly common problem on Subarus. It's very easy to replace yourself. https://www.youtube.com/watch?v=wCjhrVglaHA. Takes like 2 minutes.

Edit: The Genuine Subaru Part is made by Nissan (will have a Nissan logo on it)


3
Share
ReportSave
level 2
· 3y

This happened to me a couple months ago and I had it fixed at the dealership. Any idea on what could cause the switch to go faulty?


1
Share
ReportSave
Continue this thread 


level 2
Op · 3y
As an update I replaced the brake switch per the above and it did not correct the problem. Any other ideas?


1
Share
ReportSave
Continue this thread 


level 2
· 3y
2012, Sport Premium
Had this issue before as well, easy and quick! Just wanted to chime in and say that the part may have a Nissan logo on it, nothing to worry about.

Also, you might just be able to pop your switch out and back in, (I left a new part in the bag since this fixed it for me) or it may need a little adjusting up/down the plastic teeth.


3
Share
ReportSave
Continue this thread 


level 1
· 3y
I have this happen in my 2012 Impreza Sport when I need to get an oil change!


1
Share
ReportSave
level 2
· 3y

Happened to me on 08 wrx. I was told it was a wheel speed sensor going bad.

See more: Whatever Tomorrow Brings I Ll Be There Song, Incubus Drive, Music Videos, Bmg Music


1
Share
ReportSave
More posts from the subaruimpreza community
Continue browsing in r/subaruimpreza


*

r/subaruimpreza
A place for Impreza owners and enthusiasts to share and discuss all things Impreza.
23.0k
Members


24

Online


Created Aug 5, 2014
Join
*
*
*
*

*

Top posts october 6th 2018Top posts of october, 2018Top posts 2018
helprwcchristchurchappeal.com coinsrwcchristchurchappeal.com premiumrwcchristchurchappeal.com gifts
aboutcareerspressadvertiseblogTermsContent policyPrivacy policyMod policy
Back to Top